1015 Reversible Primes
分数 20
全屏浏览
切换布局
作者 CHEN, Yue
单位 浙江大学
A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (<10
5
) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.
Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
1.分析
1.要判断原数是否是素数,还要判断反转后的数是否为素数
2.代码
cpp
#include<iostream>
#include<cmath>
using namespace std;
const int MAX=1e6+10;
int N,D,re[MAX];
bool check(int x){ //判断是否为素数
for(int i=2;i<=x/i;i++){
if(x%i==0) return false;
}
return true;
}
int main(){
while(cin>>N){
if(N<0) break; //判断输入结束
else cin>>D;
if(N<2||!check(N)) { //判断原数
cout<<"No"<<endl;
continue;
}
int num=0;
while(N){ //反转
re[num++]=N%D;
N/=D;
}
for(int i=num-1;i>=0;i--){
N+=pow(D,num-i-1)*re[i];
}
if(N>=2&&check(N)) cout<<"Yes"<<endl; //判断
else cout<<"No"<<endl;
}
return 0;
}