fisco-bcos 关于服务bash status.sh启动runing 中但是5002端口监听不到,出错的问题

bash status.sh =============================================================================================== Server com.webank.webase.front.Application Port 5002 is running PID(4587) ===============================================================================================

yjm@yjm-VMware-Virtual-Platform:~/webase-front$ sudo netstat -anlp | grep 5002 没有端口信息输出

此时可以查看log文件夹下的WeBASE-front.log,找到报错信息如下
Error starting ApplicationContext. To display the conditions report re-run your application with 'debug' enabled. 2025-04-09 19:51:16.519 main ERROR SpringApplication() - Application run failed java.lang.IllegalStateException: Failed to execute CommandLineRunner Caused by: org.h2.jdbc.JdbcSQLNonTransientException: The database is read only; SQL statement: INFO LocalContainerEntityManagerFactoryBean() - Closing JPA EntityManagerFactory for persistence unit 'default' 2025-04-09 19:51:16.563 main INFO HikariDataSource() - HikariPool-1 - Shutdown initiated... 2025-04-09 19:51:16.570 main INFO HikariDataSource() - HikariPool-1 - Shutdown completed.

解决方案:(注意更换自己问件路径,我的webase-front目是在/home/yjm文件夹下)

强制停止残留进程

sudo pkill -9 -f "com.webank.webase.front.Application"

确认无相关进程

ps -ef | grep webase-front

复制代码
# 删除锁文件(关键步骤)
sudo rm -f /home/yjm/webase-front/h2/*.lock.db
sudo rm -f /home/yjm/webase-front/h2/*.trace.db

修改配置文件sudo nano /home/yjm/webase-front/conf/application.yml

javascript 复制代码
spring:
  datasource:
    url: jdbc:h2:file:/home/yjm/webase-front/h2/webasefront;DB_CLOSE_ON_EXIT=FALSE;AUTO_SERVER=TRUE  # 添加AUTO_SERVER
    hikari:
      connection-init-sql: "SET MODE MySQL"  # 添加此配置

再启动服务

javascript 复制代码
bash start.sh

# 实时查看日志
tail -f log/Webase-Front.log
相关推荐
姜鱼问生6 小时前
Nginx 缓存命中率监控:从 X-Cache-Status 到实时统计
运维·nginx·缓存
Apipi*6 小时前
30天速通Linux 第六章信号及信号处理
linux·运维·信号处理
天启HTTP7 小时前
爬虫防封核心原理:IP轮换机制与风控规避逻辑
linux·服务器·网络·爬虫·tcp/ip
运维行者_7 小时前
网络性能监控怎么做?从自动发现到根因分析的4个环节
运维·服务器·网络·人工智能·支持向量机
此时不提桶,更待何时8 小时前
06-14-A-Kafka集群运维与迁移实战详解
运维·kafka
广州浮点FLOATLIC9 小时前
许可证服务器迁移后软件打不开:研发 IT 怎样定位连接问题
linux·服务器·数据库
IT研究所10 小时前
AI-ITR平台如何减少客户问题反复升级?
大数据·运维·人工智能·低代码·自然语言处理·安全架构·企微
BLUcoding10 小时前
接口服务公网超时排查记录:SecureRandom 阻塞问题分析与解决
java·linux·springboot·aes·securerandom
AIgorithmGEEK10 小时前
[Linux]从手写报头到内核套路:序列化、反序列化与自定义协议全链路
linux·运维·服务器·网络·序列化·反序列化
Nil20810 小时前
leetcode 139单词拆分
linux·运维·服务器