OpenSSL

製作證書,停掉docker所佔用的80端口,啟動Ubuntu本身的Nginx。

Nginx通常在etc/nginx 目錄下,配置nginx.conf 或者 /etc/nginx/sites-available/default.

讓certbot 可以訪問到80服務。Nginx配置.well-known/acme-challenge 訪問路徑,並設置allow all權限,certbot可以寫入。

1. Create fullchain.pem and privkey.pem

复制代码
openssl req -new -nodes \
  -newkey rsa:2048 \
  -keyout privkey.pem \
  -out cert.csr \
  -config openssl.cnf

2.. Cerbot apply Let's Encrypt

复制代码
certbot certonly --manual --csr request.csr
或者

certbot certonly --webroot -w /var/www/html -d yourdomain.com
  1. /etc/nginx/sites-available 修改Nginx配置文件

    复制代码
     listen 80;
     listen [::]:80;
    
     server_name erp.vital-base.com;
    
     location /.well-known/acme-challenge/ {
         root /var/www/html;
         allow all;
     }
  2. 創建測試文件

    sudo mkdir -p /var/www/html/.well-known/acme-challenge
    echo hello | sudo tee /var/www/html/.well-known/acme-challenge/test.txt

复制代码
http://erp.vital-base.com/.well-known/acme-challenge/test.txt
  1. 結果

/var/www/html 與Nginx 保持一致

复制代码
certbot certonly --webroot -w /var/www/html -d domain.com
  1. 如果用Docker,需要掛載

    cannot load certificate "/etc/ssl/myerp/fullchain.pem"
    : BIO_new_file() failed (SSL: error:80000002:system
    library::No such file or directory:calling
    fopen(/etc/ssl/myerp/fullchain.pem, r)
    error:10000080:BIO routines::no such file)

    查看目錄下有沒有文件

    ls -l /opt/myspace/wrp/ssl2

    chmod 644 /opt/workspace/worker_myerp/ssl2/*.pem

    或者

    chmod -R 755 /opt/workspace/worker_myerp/ssl2

相关推荐
未济1 天前
linux 配置环境变量
linux
傲世仙尊1 天前
目录即文件-Ext文件系统收尾篇
linux·c语言
虎头金猫1 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
_艾伦 耶格尔.1 天前
进程间通信
linux
AI职业加油站1 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
Liuqy-051 天前
Linux IO编程——静态库、动态库
linux
此冬歌咏1 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
彧azz1 天前
Linux 环境下 Redis 学习总结:数据类型、持久化、锁、事务、主从与缓存问题
linux·redis·笔记·学习·面试
-梅1 天前
linux(8) 软硬链接
linux·运维·服务器
Wang's Blog1 天前
Java 项目实战: 外卖平台-文件下载与ServletOutputStream回写浏览器
服务器·项目开发