工作踩坑之导入数据库报错:Got a packet bigger than ‘max_allowed_packet‘ bytes

目录

问题背景

在日常开发或数据迁移过程中,使用 mysql 或客户端工具Navicat/Dbeaver/DataGrip等导入 .sql 文件时,可能会遇到如下错误:

sql 复制代码
ERROR 1153 (08S01): Got a packet bigger than 'max_allowed_packet' bytes

问题原因

MYSQL限制了每次执行插入操作的数据最大值,超过最大值则报以上错误。这个系统参数: max_allowed_packet;一般情况下,服务器默认max-allowed-packet为1MB,客户端的max-allowed-packet为16MB。

解决方案

使用命令SHOW VARIABLES LIKE 'max_allowed_packet'; 可以查看这个值的大小

方案一:

-- 在MySQL客户端中执行

sql 复制代码
SET GLOBAL max_allowed_packet = 512*1024*1024;

-- 然后退出重新连接,或者继续执行导入

方案二:

在MYSQL的配置文件my.ini中加入

bash 复制代码
[mysqld]
max_allowed_packet = 512M

然后重启MYSQL。

好文推荐:
工作踩坑之MySql 5.7及以上版本使用select group by报错
工作踩坑之Collectors.toMap实战
工作踩坑之前端明明传值了,但是springboot为什么接收不到?到底是谁的坑?

相关推荐
苍何6 小时前
开源微信流 Windows,微信聊天记录,可以直接给 Codex 和 Obsidan 了
后端
蜡笔婧萱6 小时前
Docker介绍及其基础简介(一)
云原生·eureka
IvorySQL6 小时前
PostgreSQL 日报|修复截断 zstd 备份检测(10 月 9 日)
数据库·postgresql
刘胡子大叔7 小时前
SQL 脚本的导入顺序
数据库·sql
代码什么用7 小时前
Spring基础使用
java·后端·spring
代码什么用7 小时前
Spring对IoC的实现
数据库·spring
Su米苏7 小时前
Spring AI 中MCP 与普通 @Tool的区别
java·人工智能·spring
明月_清风8 小时前
Deno 终局来了:从挑战 Node 到被 Cloudflare 收编
前端·后端·node.js
码云数智-园园8 小时前
unique_ptr 还是 shared_ptr?C++ 智能指针选型与内存泄漏实战分析
java·开发语言
老板一杯拿铁8 小时前
Java 异常体系详解:从字节码原理到最佳实践
java