Linux|服务器|简单记录备忘VMware虚拟机开启桌面失败报错:VMware: No 3D enabled (0, Success).的解决

一,

VMware虚拟机 Linux操作系统,centos7版本,安装完桌面后,执行startx 命令后 ,报错:VMware: No 3D enabled (0, Success). 桌面没有启动成功

完整日志输出如下:

bash 复制代码
[root@node4 ~]# startx
xauth:  file /root/.serverauth.2982 does not exist


X.Org X Server 1.19.3
Release Date: 2017-03-15
X Protocol Version 11, Revision 0
Build Operating System:  3.10.0-514.16.1.el7.x86_64 
Current Operating System: Linux node4 3.10.0-1062.el7.x86_64 #1 SMP Wed Aug 7 18:08:02 UTC 2019 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-3.10.0-1062.el7.x86_64 root=/dev/mapper/centos-root ro rd.lvm.lv=centos/root rhgb quiet LANG=en_US.UTF-8
Build Date: 05 August 2017  06:19:43AM
Build ID: xorg-x11-server 1.19.3-11.el7 
Current version of pixman: 0.34.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jan  6 13:29:56 2024
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
VMware: No 3D enabled (0, Success).
touch: cannot touch '/root/.cache/imsettings/log': No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory

(imsettings-check:3091): IMSettings-WARNING **: 13:29:56.382: Failed to execute child process "dbus-launch" (No such file or directory)

(imsettings-check:3091): GLib-GIO-CRITICAL **: 13:29:56.382: g_dbus_proxy_call_sync_internal: assertion 'G_IS_DBUS_PROXY (proxy)' failed
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
/usr/libexec/imsettings-functions: line 37: /root/.cache/imsettings/log: No such file or directory
xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

解决方案:

VMware虚拟机关闭后,把这个勾打上,然后在启动虚拟机,再次执行startx命令,成功进入桌面

二,

多个桌面是否可以同时存在?

答案是肯定的,多个桌面可以同时存在,例如GNOME和KDE是可以共存的,只是在使用桌面的时候需要指定使用哪个桌面而已。

三,

GNOME和KDE安装时的应注意事项

通常桌面不需要外部yum源,只使用操作系统ISO搭建的本地仓库,如果有依赖报错,必须手动排除掉,不能强制安装。

四,

GNOME桌面的安装:

bash 复制代码
yum groupinstall "GNOME Desktop"

KDE桌面的安装:

bash 复制代码
yum groupinstall "GNOME Desktop"

五,

桌面启动的方式

GNOME前台启动方式在centos7下是 startx 命令(如果是在xshell下面)

GNOME后台启动方式在centos7下是systemctl isolate graphical.target(如果是在xshell下面)

KDE前台启动方式:

bash 复制代码
[root@centos4 ~]# echo "exec startkde">>~/.xinitrc
[root@centos4 ~]# startx

启动后前台持续打印日志:

bash 复制代码
xauth:  file /root/.serverauth.1713 does not exist


X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
Build Operating System:  3.10.0-957.1.3.el7.x86_64 
Current Operating System: Linux centos4 3.10.0-1062.el7.x86_64 #1 SMP Wed Aug 7 18:08:02 UTC 2019 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-3.10.0-1062.el7.x86_64 root=/dev/mapper/centos-root ro rd.lvm.lv=centos/root rhgb quiet LANG=en_US.UTF-8
Build Date: 09 August 2019  03:27:09AM
Build ID: xorg-x11-server 1.20.4-7.el7 
Current version of pixman: 0.34.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jan  6 19:14:49 2024
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
VMware: No 3D enabled (0, Success).
startkde: Starting up...
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
。。。。。。。略略略。。。。。。
相关推荐
l1t10 小时前
修复WSL CreateInstance/E_UNEXPECTED和 mounted read-only 错误
linux·windows·wsl
Ruiery10 小时前
Linux 6.6内核 CPU 深度解析(九):时钟与 TSC — 内核怎么从 PIT/HPET 切到 TSC
linux·运维·服务器
吴声子夜歌11 小时前
Nginx应用与运维——Nginx日志管理
java·运维·nginx
打工仔折腾 AI11 小时前
用UU远程把家里电脑变成AI Agent常驻服务器:CLI、端口映射与代理实测
运维·服务器·人工智能·后端·python·电脑·ai agent 实战
91刘仁德11 小时前
Linux网络编程从入门到实战:UDP/TCP协议与socket编程全解析
linux·网络·笔记·tcp/ip·udp
guo_wen_qiang11 小时前
云服务器nacos搭建-集群&持久化
java·运维·服务器
水饺编程11 小时前
第1章:下载 Linux 0.12 内核
linux·c语言·汇编·ubuntu
牢姐与蒯11 小时前
一点小碎片——每个线程独有的东西——上下文+栈
linux·运维·服务器
小此方11 小时前
Linux网络(二十):TCP拥塞控制与延迟应答详解:从拥塞窗口到TCP性能优化,理解TCP与UDP的效率差异
linux·网络·php
yunwei3712 小时前
eBPF 开发实践:使用 eBPF 隐藏进程或文件信息
linux·后端·性能优化