msyql中SQL 错误 [1118] [42000]: Row size too large (> 8126)

场景:

复制代码
CREATE TABLE `test-qd`.eqtree (
	`INSERT INTO test.eqtree (idocid` VARCHAR(50) NULL,
	sfcode VARCHAR(50) NULL,
	sfname VARCHAR(50) NULL,
	sfengname VARCHAR(50) NULL,
	......
)
ENGINE=InnoDB
DEFAULT CHARSET=utf8
COLLATE=utf8_general_ci;

或

复制代码
alter  table eqtree modify  column DMODT  varchar(20) ;

SQL 错误 1118 42000: Row size too large (> 8126). Changing some columns to TEXT or BLOB may help. In current row format, BLOB prefix of 0 bytes is stored inline.

临时解决办法:

执行以下SQL语句,查看严格模式是否开启

show variables like '%innodb_strict_mode%';

执行后如果为​​ON​​,则需要关闭

set global innodb_strict_mode=0;

此方式下基于会话级别

完成后恢复

set global innodb_strict_mode=1;

或更新my.ini​​,在mysqld配置项下面新增一行

复制代码
[mysqld]
innodb_strict_mode=0

根本原因分析:

这个错误通常是由于MySQL表中的行过大而引起的。MySQL有一些限制,其中一个是行的最大大小不能超过特定的限制,通常为65,535个字节。在你的情况下,行的大小超过了这个限制,导致了错误1118的出现。

要解决这个问题,你可以考虑以下几种方法:

优化表结构:检查表的设计,尝试减少每行所占用的空间。这可能包括删除不必要的列,使用更紧凑的数据类型,或将较大的列(如TEXT或BLOB)移出主表并将其替换为引用表。

使用TEXT或BLOB类型:根据错误消息的建议,将较大的列(如文本或二进制数据)改为TEXT或BLOB类型。这将使得存储在这些列中的数据不会直接存储在行中,而是存储在单独的页中。

分割表:如果可能的话,将表拆分成多个相关联的表,以减少每个表行的大小。

使用InnoDB的压缩功能:InnoDB引擎提供了行压缩功能,可以减少行的存储空间。你可以考虑启用InnoDB的压缩功能来减少表的存储空间。

借助对表分析:

SHOW TABLE STATUS LIKE 'eqtree';

待完善......

相关推荐
2501_9336707920 分钟前
2027届大数据管理与应用求职数字化转型顾问:项目、SQL、业务理解怎么排优先级
数据库·sql
rm -rf * && haha.sh2 小时前
【Linux】Rocky 9.8 操作系统磁盘分区与MySQL数据目录迁移
linux·运维·mysql
资深技术分享员3 小时前
Geejing WebBuilder 数据库连接配置与在线 SQL 工具,运维的左右手
运维·数据库·sql·低代码
ao-weilai3 小时前
MySQL数据库:表操作
数据库·mysql·adb
宵时待雨3 小时前
MySQL数据库1:数据库基础
服务器·数据库·mysql
做运维的阿瑞3 小时前
一个 NULL 让整列姓名消失?MySQL 字符串与日期函数复盘
数据库·sql·mysql
阳光九叶草LXGZXJ4 小时前
达梦数据库-学习-69-DM9主备集群部署
linux·运维·服务器·数据库·sql·学习
在猴站学算法5 小时前
(SQL注入学习)联合查询注入(UNION-Based)
sql·学习·网络安全
Dxy12393102165 小时前
MySQL 条件注释语法
数据库·mysql
小小龙学IT5 小时前
Go 语言 database/sql 标准库深度解析:从连接池到驱动抽象
数据库·sql·golang