密码学基础--搞清RFC和PKCS(1)

目录

[1. CryptoDriver里KeyElement格式](#1. CryptoDriver里KeyElement格式)

[2. 挖掘RFC标准](#2. 挖掘RFC标准)

3.小结


昨天从生成密钥对开始逐步了解了公钥、证书等各种编码方式,今天继续趁热打,做一个理论知识汇总。

Ps:我只是标准的翻译搬运工。

1. CryptoDriver里KeyElement格式

在 CryptoKeyElement 配置项里,我们会发现有format这类格式,如下图:

根据规范解释如下:

|----------------------------------------------|----------------------------------|
| CRYPTO_KE_FORMAT_BIN_OCTET | 以BIN形式提供八位字节值的Key |
| CRYPTO_KE_FORMAT_BIN_SHEKEYS | 用于SHE key更新的组合Key |
| CRYPTO_KE_FORMAT_BIN_IDENT_PRIVATEKEY_ PKCS8 | ASN.1定义的带ID的私钥格式(BER编码),以BIN形式提供 |
| CRYPTO_KE_FORMAT_BIN_IDENT_PUBLICKEY | ASN.1定义的带ID的公钥格式(BER编码),以BIN形式提供 |
| CRYPTO_KE_FORMAT_BIN _RSA_PRIVATEKEY | ASN.1定义的私钥格式(BER编码),以二进制提供 |
| CRYPTO_KE_FORMAT_BIN _RSA_PUBLICKEY | ASN.1定义的公钥格式(BER编码),以二进制提供 |

可以看到,针对非对称密钥对的格式,是可以选择是否带ID的,而这所有的一切都源于ASN.1。

回顾一下:

  • ASN.1(Abstract Syntax Notation One)是一种用于描述数据结构的标记语言,最初由国际电信联盟(ITU-T)定义,用于在计算机网络和通信协议中描述数据格式。ASN.1提供了一种独立于具体编程语言的方式来描述数据结构,使得不同系统之间可以共享和理解数据。
  • ASN.1的编码规则有多种,其中最常见的是BER(Basic Encoding Rules)、DER(Distinguished Encoding Rules)和PER(Packed Encoding Rules)。这些编码规则定义了如何将ASN.1中定义的数据类型编码为二进制格式,并在需要时进行压缩以减少数据传输的大小。

2. 挖掘RFC标准

那么上述KeyElement的格式应该长什么样?是否有关联标准?

参考【SWS_Crypto_00184-00188】,汇总如下:

|----------------------------------------------|---------|
| CRYPTO_KE_FORMAT_BIN_IDENT_PRIVATEKEY_ PKCS8 | RFC5958 |
| CRYPTO_KE_FORMAT_BIN_IDENT_PUBLICKEY | RFC5280 |
| CRYPTO_KE_FORMAT_BIN _RSA_PRIVATEKEY | RFC8017 |
| CRYPTO_KE_FORMAT_BIN _RSA_PUBLICKEY | RFC5280 |

3.小结

老规矩,先从RFC是什么开始说起,但是限于篇幅放到下一篇文章了,下篇文章我们将深挖RFC和PKCS

相关推荐
酿情师21 小时前
CTF Crypto Lab — 密码学方向 CTF 本地训练场
密码学
小豆庄1 天前
视频隐私脱敏怎么处理:识别追踪与本地方案的选型思路
密码学·音视频·视频
曼岛_2 天前
[图解密码学]第4章 古典密码
java·数据库·密码学
HackTwoHub3 天前
双通道红队 C2,MCP 接入 AI,全自动渗透实战利器,具备自动提权、进程伪装、无文件上线能力,载荷 AES 加密
安全·web安全·网络安全·系统安全·密码学·可信计算技术·安全架构
幻智星科技5 天前
蒙哥马利模乘FPGA优化实战
fpga开发·密码学
kobe_t5 天前
数据安全系列10:密码大历史-凯撒加密
密码学
洁洁!8 天前
SM2签名验证深度解析
密码学·国密·sm2
幻智星科技9 天前
Karatsuba与CSD优化FPGA大数乘法
c++·fpga开发·密码学
deepseek2318 天前
AI 模型隐藏任意能力拆解:把加密神经网络塞进宿主权重,能力评估为什么在密码学上抓不到
人工智能·深度学习·神经网络·密码学·模型安全
Lsetea20 天前
OpenSSL读取加密私钥报bad decrypt:passin与口令来源排查
linux·https·ssl证书·openssl·私钥