bitbake ERROR:No space left on device or exceeds fs.inotify.max_user_watches?

使用vscode remote ssh来编辑服务器上源码后,执行bitbake编译时,遇到了如下报错:ERROR:No space left on device or exceeds fs.inotify.max_user_watches?

可能的解决方法和原因:

首先可以尝试关闭vscode ,然后在服务器再次运行bitbake命令,大概率这次可以运行成功了。
出现这个问题的原因是:

当你看到这个通知时,它表明VS Code文件监视器的文件句柄已经用完了,而这些句柄是实现文件监视所需要的。在打开一个很大且包含许多文件的工作空间时,通常会发生这种情况。在调整平台限制之前,请确保将可能较大的文件夹(如Python .venv)添加到文件中。watcherExclude设置(下面有更多细节)。也有可能其他正在运行的应用程序消耗了太多的文件句柄,以至于没有留下任何文件句柄供VS Code使用。在这种情况下,关闭这些其他应用程序可能会有所帮助。

可以通过运行命令查看当前限制:

bash 复制代码
cat /proc/sys/fs/inotify/max_user_watches

通过编辑/etc/sysctl.conf (Arch Linux除外,请阅读下文)并在文件末尾添加这一行,可以将限制增加到最大:

bash 复制代码
fs.inotify.max_user_watches=524288

然后可以通过运行sudo sysctl -p加载新值。

虽然524,288是可以监视的最大文件数,但如果您在一个内存特别受限的环境中,您可能希望降低这个数字。每个文件监视占用1080字节,因此假设所有524,288个监视都被消耗掉,结果是大约540 MiB的上限。

相关推荐
海绵宝宝转agent6 小时前
learn-claude-code第1-5章开源学习笔记分享
人工智能·笔记·python·学习
Ruiery6 小时前
Linux 6.6内核 CPU 深度解析(七):调度器启动 — 从单核到多核,调度器分阶段点亮
linux·运维·服务器
50万马克的面包7 小时前
CSDN-栈队列数组-知识点整理
linux·运维·服务器
wjkjpcba8 小时前
PCBA烧录程序是什么:PCBA包工包料厂家解析烧录与测试
linux·数据库·人工智能·smt贴片加工·pcba贴片加工厂
꯭自꯭闭꯭8 小时前
达梦事物特性及MVCC
linux·运维·数据库
91刘仁德9 小时前
HTTP协议详解:从URL到HTTP服务器的完整实战
服务器·网络·笔记·网络协议·http
羔羊++10 小时前
18_实验十七_其他命令与自定义启动变量
linux
柳鲲鹏12 小时前
老电脑X99安装WIN11 26H2总结、问题解决办法汇总
笔记
DYWorker00112 小时前
Linux驱动:RK3568 GMAC + YT8531C 千兆以太网全流程解剖
linux
lisanmengmeng13 小时前
NRPE 添加命令(一)
linux·运维·服务器