bitbake ERROR:No space left on device or exceeds fs.inotify.max_user_watches?

使用vscode remote ssh来编辑服务器上源码后,执行bitbake编译时,遇到了如下报错:ERROR:No space left on device or exceeds fs.inotify.max_user_watches?

可能的解决方法和原因:

首先可以尝试关闭vscode ,然后在服务器再次运行bitbake命令,大概率这次可以运行成功了。
出现这个问题的原因是:

当你看到这个通知时,它表明VS Code文件监视器的文件句柄已经用完了,而这些句柄是实现文件监视所需要的。在打开一个很大且包含许多文件的工作空间时,通常会发生这种情况。在调整平台限制之前,请确保将可能较大的文件夹(如Python .venv)添加到文件中。watcherExclude设置(下面有更多细节)。也有可能其他正在运行的应用程序消耗了太多的文件句柄,以至于没有留下任何文件句柄供VS Code使用。在这种情况下,关闭这些其他应用程序可能会有所帮助。

可以通过运行命令查看当前限制:

bash 复制代码
cat /proc/sys/fs/inotify/max_user_watches

通过编辑/etc/sysctl.conf (Arch Linux除外,请阅读下文)并在文件末尾添加这一行,可以将限制增加到最大:

bash 复制代码
fs.inotify.max_user_watches=524288

然后可以通过运行sudo sysctl -p加载新值。

虽然524,288是可以监视的最大文件数,但如果您在一个内存特别受限的环境中,您可能希望降低这个数字。每个文件监视占用1080字节,因此假设所有524,288个监视都被消耗掉,结果是大约540 MiB的上限。

相关推荐
还卿一钵无情泪9 小时前
Unsloth 微调 构建自己的大模型 没有GPU也能微调
linux·开发语言·人工智能·python·大模型·nlp·unsloth
高山有多高9 小时前
【Linux笔记】IO模型
linux
不会就选b10 小时前
Linux之TCP理论<1>
linux·运维·服务器
小π军11 小时前
操作系统面试题
java·linux·服务器
Lsetea12 小时前
curl用IP测试HTTPS报证书不匹配:--resolve与Host头别混用
linux·https·ssl证书·openssl·curl
Hao28512 小时前
Windows11 下把 WSL2 Ubuntu 26.04 装到 D 盘完整
linux
Android系统攻城狮12 小时前
Linux Gstreamer深度解析之gst_audio_encoder_get_frame_samples_min调用流程与实战(六十)
linux·运维·服务器·音视频·gstreamer音视频·音视频进阶·gstreamer音视频进阶
_upupup13 小时前
Linux中的自动化构建——make/Makefile
linux·运维·自动化
HEJOO913 小时前
Linux 设备驱动系列——使用全局工作队列
java·linux·算法
一隅论数智14 小时前
OWL(Web Ontology Language)介绍与使用举例(二)
大数据·经验分享·笔记·学习·自然语言处理·学习方法·政务