atcoder ABC 355-C题详解

atcoder ABC 355-C题详解

Problem Statement

There is an N×N grid, where the cell at the i-th row from the top and the j-th column from the left contains the integer N×(i−1)+j.

Over T turns, integers will be announced. On Turn i, the integer Ai​ is announced, and the cell containing Ai​ is marked. Determine the turn on which Bingo is achieved for the first time. If Bingo is not achieved within T turns, print -1.

Here, achieving Bingo means satisfying at least one of the following conditions:

There exists a row in which all N cells are marked.

There exists a column in which all N cells are marked.

There exists a diagonal line (from top-left to bottom-right or from top-right to bottom-left) in which all N cells are marked.

Constraints

2≤N≤2×103

1≤T≤min(N2,2×105)

1≤Ai​≤N2

Ai​=Aj​ if i=j.

All input values are integers.

Input

The input is given from Standard Input in the following format:

Output

If Bingo is achieved within T turns, print the turn number on which Bingo is achieved for the first time; otherwise, print -1.

Sample Input 1

3 5

5 1 8 9 7

Sample Output 1

4

The state of the grid changes as follows. Bingo is achieved for the first time on Turn 4.

Sample Input 2

​3 5

4 2 9 7 5

Sample Output 2

-1

Bingo is not achieved within five turns, so print -1.

Sample Input 3

4 12

13 9 6 5 2 7 16 14 8 3 10 11

Sample Output 3

9

思路分析:

先判断输入的数字在哪一行那一列,然后判断是否符合宾果游戏规则,判断主对角线和次对角线以及行、列。

code:

cpp 复制代码
#include <iostream>
using namespace std;
const int N = 2010;
int n, t;
int row[N];
int col[N];
int ans1, ans2;
int main() {
    cin >> n >> t;
    for (int i = 0; i < t; i++) {
        int a;
        cin >> a;
        a--;//要减一比如5,5/3=1,5%3=2
        int row1 = a / n;
        int col1 = a % n;
//        if (row1 >= n || col1 >= n) {不需要比如第一个样例9/3=3 直接输出-1结束程序了
//            cout << "-1" << endl;
//            return 0;
//        }
        row[row1]++;
        col[col1]++;
        // 检查主对角线
        if (row1 == col1) {
         ans1++;
        }
        // 检查次对角线
        if (row1 + col1 == n - 1) {
         ans2++;
        }
        if(ans1 == n || ans2 == n) {
         cout << i + 1 << endl;
         return 0;
  }
        // 检查行和列
        if (row[row1] == n || col[col1] == n) {
            cout << i + 1 << endl;
            return 0;
        }
    }
    cout << "-1" << endl;
    return 0;
}
相关推荐
m0Java门徒几秒前
面向对象编程核心:封装、继承、多态与 static 关键字深度解析
java·运维·开发语言·intellij-idea·idea
liuweidong08022 分钟前
【Pandas】pandas DataFrame radd
开发语言·python·pandas
我也不曾来过128 分钟前
list底层原理
数据结构·c++·list
A charmer34 分钟前
C++ 日志系统实战第三步:熟悉掌握各种设计模式
c++·日志系统
农民也会写代码35 分钟前
dedecms织梦arclist标签noflag属性过滤多个参数
开发语言·数据库·sql·php·dedecms
Ethon_王44 分钟前
STL容器适配器详解:queue篇
c++
静听夜半雨1 小时前
CANoe入门——3、新建LIN工程及LIN DataBase(LDF文件)的创建
网络·数据库·c++·编辑器
内网渗透1 小时前
Python 虚拟环境管理:venv 与 conda 的选择与配置
开发语言·python·conda·虚拟环境·venv
embedded_w1 小时前
U8G2在PC端模拟(C语言版本)
c语言
梁下轻语的秋缘1 小时前
每日c/c++题 备战蓝桥杯 ([洛谷 P1226] 快速幂求模题解)
c++·算法·蓝桥杯