k8s容器启动不了,一直重启, 报红提示Not Ready

k8s容器启动不了,一直重启, 报红提示Not Ready

反复多次重启后,才能够启动成功。

发现是 启动时间过长,不断达到了失败阈值,于是会不断重启。

将 failureThreshold、 initialDelaySeconds、periodSeconds 这几个参数设置大一些,就可以启动了。

k8s探针类型及探针配置:

详情见: https://blog.csdn.net/sinat_32502451/article/details/139837159

示例:

复制代码
		  livenessProbe:
            failureThreshold: 6
            httpGet:
              path: /my-service/act/health
              port: 8110
              scheme: HTTP
            initialDelaySeconds: 60
            periodSeconds: 20
            successThreshold: 1
            timeoutSeconds: 5
          name: my-service
          ports:
            - containerPort: 8110
              protocol: TCP
          readinessProbe:
            failureThreshold: 6
            httpGet:
              path: /my-service/act/health
              port: 8110
              scheme: HTTP
            initialDelaySeconds: 60
            periodSeconds: 20
            successThreshold: 1
            timeoutSeconds: 5
相关推荐
念何架构之路2 小时前
zap日志SugaredLogger 剖析
云原生·golang
LBL12203 小时前
内网容器部署FTP日志监控服务
运维·服务器·容器
阿里云云原生4 小时前
云效智能评审:让团队规则持续生效
云原生
阿里云云原生4 小时前
智能聚类:从海量 Trace 中理解 Agent 的行为和表现
云原生·agent
阿里云云原生4 小时前
云栖丨AI 应用进入生产,开始拼「实时数据智能」
云原生
溜达的大象5 小时前
极空间部署Traggo时间追踪工具:Docker安装、标签管理与cpolar远程访问
运维·docker·容器
脏脏a5 小时前
极空间部署 Dashlet:Docker 搭建私人导航仪表盘,再配置固定公网访问
运维·docker·容器
运维开发王义杰5 小时前
跳出网络与文件系统:Linux CPU 与内存调优的“防假死”实战
云原生
User_芊芊君子6 小时前
Prometheus接入Pushgateway实战:二进制与Docker部署、指标推送及远程上报
docker·容器·prometheus
江湖有缘7 小时前
3款开源日记工具整理合集,可Docker一键部署!
docker·容器·开源