【笔记】手工部署之linux中开放已安装的mysql与tomcat端口

在需要打包的springboot项目中输入mvn clean package

在target下面获得jar包

进入linux中你想要该jar包存在的位置

将jar包上传至linux中

此时在浏览器中输入linux的ip地址:端口号/mapping路径为404

故:

在linux中另开一个标签页

检查mysql和tomcat已开放端口号

如果输入firewall-cmd --zne=public --list-ports返回为空则

端口开放成功

解决本地部署霸屏问题 启用后台运行

  • &>:这个组合操作符意味着把命令的所有输出(包括标准输出和标准错误)都重定向到文件 hello.log 中。
  • hello.log:这是接收重定向输出的日志文件。
  • &:把命令放到后台执行。

此时再向浏览器网址栏输入linux的ip地址:端口号/mapping路径 可以正常的展示页面内容 即使断掉linux的连接可以正常展示

相关推荐
蓝速科技1 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
chicheese2 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky2 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南3 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
vortex53 小时前
常用终端模拟器全面对比:Kitty、WezTerm、Ghostty 与 Konsole
linux
我命由我123453 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人3 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender4 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
INGNIGHT4 小时前
270 · 电话号码的字母组合II(Trie)
linux·算法
zly35004 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器