k8s报错Error getting node“ err=“node \“k8smaster\“ not found

在初始化K8S时候,遇到以下错误

复制代码
Unfortunately, an error has occurred:
		timed out waiting for the condition

	This error is likely caused by:
		- The kubelet is not running
		- The kubelet is unhealthy due to a misconfiguration of the node in some way (required cgroups disabled)

	If you are on a systemd-powered system, you can try to troubleshoot the error with the following commands:
		- 'systemctl status kubelet'
		- 'journalctl -xeu kubelet'

	Additionally, a control plane component may have crashed or exited when started by the container runtime.
	To troubleshoot, list all containers using your preferred container runtimes CLI.

	Here is one example how you may list all Kubernetes containers running in docker:
		- 'docker ps -a | grep kube | grep -v pause'
		Once you have found the failing container, you can inspect its logs with:
		- 'docker logs CONTAINERID'

error execution phase wait-control-plane: couldn't initialize a Kubernetes cluster
To see the stack trace of this error execute with --v=5 or higher

E0815 14:16:57.735202   68860 kubelet.go:2461] "Error getting node" err="node \"k8smaster\" not found"

服务虽然启动着,但是节点没有被发现

排查过主机名配置的没问题,hosts文件配置也没问题

最后发现是,初始化的 --apiserver-advertise-address 集群master地址 配置的和主机的IP不一致才导致初始化异常报错

将集群master地址与主机IP地址改为一致的地址

然后重置kubeadm并重新加载kubelet服务

当前master节点重置kubeadm
kubeadm reset -f

重新加载kubelet服务
systemctl daemon-reload && systemctl restart kubelet

相关推荐
Henry-SAP14 小时前
SAP MRP失效根源业务角度解析
人工智能·云原生·sap·erp
江湖有缘19 小时前
3款开源绘图工具整理合集,可Docker一键部署!
docker·容器·开源
nhdh20 小时前
Higress:AI时代云原生网关新选择
人工智能·云原生
小匠石钧知1 天前
06_在k8s集群中安装MetalLB实现LoadBalancer
云原生·容器·kubernetes·service·loadbalancer·metallb
troy1282 天前
阿里云 vs 谷歌云:Kubernetes 部署深度对比分析
阿里云·kubernetes·云计算
谢亮_vipxieliang2 天前
容器排障实战手册:从日志到内核的分层排障
docker·云原生·容器·eureka
wzq11_6662 天前
Kubernetes集群——Pod篇
云原生·容器·kubernetes
wzq11_6662 天前
Kubernetes集群——命令篇
云原生·容器·kubernetes
小白的码BUG之路2 天前
Docker -- 构建ruoyi-gateway镜像
docker·容器·gateway
小白的码BUG之路2 天前
Docker -- 构建ruoyi-system镜像
运维·docker·容器