Codeforces 1304C - Air Conditioner(1500)

Air Conditioner

题面翻译

  • 一个餐馆中有个空调,每分钟可以选择上调 1 1 1 个单位的温度或下调 1 1 1 个单位的温度,当然你也可以选择不变,初始的温度为 m m m 。

  • 有 n n n 个食客,每个食客会在 t i t_i ti 时间点到达,他所能适应的最低温度是 l i l_i li ,最高温度是 h i h_i hi ,他只会在 t i t_i ti 时刻逗留。

  • 如果温度不在食客的适应范围内,他就会不舒服,请你判断,空调能否使得 n n n 位来就餐的食客都感到舒服。

  • 本题多组数据 ,数据组数不大于 500 500 500。

  • 1 ≤ n ≤ 100 1\le n\le 100 1≤n≤100, − 1 0 9 ≤ m , l i , h i ≤ 1 0 9 -10^9\le m,l_i,h_i\le 10^9 −109≤m,li,hi≤109, 1 ≤ t i ≤ 1 0 9 1\le t_i\le 10^9 1≤ti≤109。

  • translate by @ShineEternal

题目描述

Gildong owns a bulgogi restaurant. The restaurant has a lot of customers, so many of them like to make a reservation before visiting it.

Gildong tries so hard to satisfy the customers that he even memorized all customers' preferred temperature ranges! Looking through the reservation list, he wants to satisfy all customers by controlling the temperature of the restaurant.

The restaurant has an air conditioner that has 3 states: off, heating, and cooling. When it's off, the restaurant's temperature remains the same. When it's heating, the temperature increases by 1 in one minute. Lastly, when it's cooling, the temperature decreases by 1 in one minute. Gildong can change the state as many times as he wants, at any integer minutes. The air conditioner is off initially.

Each customer is characterized by three values: $ t_i $ --- the time (in minutes) when the $ i $ -th customer visits the restaurant, $ l_i $ --- the lower bound of their preferred temperature range, and $ h_i $ --- the upper bound of their preferred temperature range.

A customer is satisfied if the temperature is within the preferred range at the instant they visit the restaurant. Formally, the $ i $ -th customer is satisfied if and only if the temperature is between $ l_i $ and $ h_i $ (inclusive) in the $ t_i $ -th minute.

Given the initial temperature, the list of reserved customers' visit times and their preferred temperature ranges, you're going to help him find if it's possible to satisfy all customers.

输入格式

Each test contains one or more test cases. The first line contains the number of test cases $ q $ ( $ 1 \le q \le 500 $ ). Description of the test cases follows.

The first line of each test case contains two integers $ n $ and $ m $ ( $ 1 \le n \le 100 $ , $ -10^9 \le m \le 10^9 $ ), where $ n $ is the number of reserved customers and $ m $ is the initial temperature of the restaurant.

Next, $ n $ lines follow. The $ i $ -th line of them contains three integers $ t_i $ , $ l_i $ , and $ h_i $ ( $ 1 \le t_i \le 10^9 $ , $ -10^9 \le l_i \le h_i \le 10^9 $ ), where $ t_i $ is the time when the $ i $ -th customer visits, $ l_i $ is the lower bound of their preferred temperature range, and $ h_i $ is the upper bound of their preferred temperature range. The preferred temperature ranges are inclusive.

The customers are given in non-decreasing order of their visit time, and the current time is $ 0 $ .

输出格式

For each test case, print "YES" if it is possible to satisfy all customers. Otherwise, print "NO".

You can print each letter in any case (upper or lower).

样例 #1

样例输入 #1

4
3 0
5 1 2
7 3 5
10 -1 0
2 12
5 7 10
10 16 20
3 -100
100 0 0
100 -50 50
200 100 100
1 100
99 -100 0

样例输出 #1

YES
NO
YES
NO

提示

In the first case, Gildong can control the air conditioner to satisfy all customers in the following way:

  • At $ 0 $ -th minute, change the state to heating (the temperature is 0).
  • At $ 2 $ -nd minute, change the state to off (the temperature is 2).
  • At $ 5 $ -th minute, change the state to heating (the temperature is 2, the $ 1 $ -st customer is satisfied).
  • At $ 6 $ -th minute, change the state to off (the temperature is 3).
  • At $ 7 $ -th minute, change the state to cooling (the temperature is 3, the $ 2 $ -nd customer is satisfied).
  • At $ 10 $ -th minute, the temperature will be 0, which satisfies the last customer.

In the third case, Gildong can change the state to heating at $ 0 $ -th minute and leave it be. Then all customers will be satisfied. Note that the $ 1 $ -st customer's visit time equals the $ 2 $ -nd customer's visit time.

In the second and the fourth case, Gildong has to make at least one customer unsatisfied.

思路:根据题意我们可以知道初始的温度及时间是确定的,且时间是不递减的,我们可以维护一个温度区间与所给的每一个顾客的时间区间取交集如果有一个为空的即为NO,维护交集写法如下

AC代码:

cpp 复制代码
#include<bits/stdc++.h>

using namespace std;

typedef long long ll;
typedef pair<int, int>PII;
typedef pair<int, double>PDD;
const int N=2e5 +10;
const int MOD = 1e9 + 7;
const int INF=0X3F3F3F3F;
const int dx[]={-1,0,1,0,-1,-1,+1,+1};
const int dy[]={0,1,0,-1,-1,+1,-1,+1}; 

//马
const int dxx[]={-1,2,1,1,-1,2,-2,-2};
const int dyy[]={2,1,-2,2,-2,-1,-1,1};    
const int M = 1e7 + 10;

ll n;
ll t[N], l[N], r[N];

int main()
{
	int T;
	cin >> T;
	while(T --){
		int n, m;
		cin >> n >> m;
		for(int i = 1; i <= n; i ++)
		{
			cin >> t[i] >> l[i] >> r[i];
		}
		ll cha = 0, f = 0;
		//维护一个温度区间 
		ll l1 = m, r1 = m;//一开始均属于初始温度//当前时间为0
		for(int i = 1; i <= n; i ++)
		{
			cha = t[i] - t[i - 1];//两者的时间差
			l1 -= cha , r1 += cha;
		    //取交集依次取依次变
			l1 = max(l1, l[i]), r1 = min(r1, r[i]);
			if(l1 > r1)
			{
				f = 1;
				break;
			}
		}
		if(f) puts("NO");
		else puts("YES");
	}
	return 0;
}
相关推荐
cat_fish_rain1 小时前
使用Qt 搭建简单雷达
开发语言·c++·qt
埋头编程~1 小时前
【初阶数据结构】详解树和二叉树(一) - 预备知识(我真的很想进步)
c语言·数据结构·c++·学习
小陈的进阶之路1 小时前
c++刷题
开发语言·c++·算法
毅凉1 小时前
C/C++笔记
c语言·c++
游凡~1 小时前
【C++】虚函数
开发语言·c++
model20051 小时前
sahi目标检测java实现
java·算法·目标检测
源代码•宸2 小时前
Leetcode—322. 零钱兑换【中等】(memset(dp,0x3f, sizeof(dp))
c++·算法·leetcode·职场和发展·dp
机械心2 小时前
最优化理论与自动驾驶(一):概述
人工智能·算法·自动驾驶
给自己做减法2 小时前
排序算法快速记忆
java·算法·排序算法
初级代码游戏2 小时前
国密起步6:GmSSL3使用SM4自定义格式加解密C++版
c++·国密·sm4