OpenJudge | Shortest Prefixes

总时间限制: 1000ms 内存限制: 65536kB

描述

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo".

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car".

输入

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

输出

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

样例输入

cpp 复制代码
carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

样例输出

cpp 复制代码
carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

思路

  1. 先创建一个字典树,然后将所有的单词插入到字典树中。
  2. 对于每一个单词,从根节点开始,如果当前节点的子节点数为1,那么就继续往下走,直到找到一个子节点数为1或者到达单词的末尾。
  3. 输出这个单词和这个单词的前缀。

参考代码

cpp 复制代码
#include <bits/stdc++.h>
using namespace std;

struct node {
    unordered_map<char, node*> mp;
    int count, isEnd;
} root;

vector<pair<string,string>> res;

void abjust(string s) {
    node *p = &root;
    for(int i = 0; i < s.size(); ++i) {
        if(p->mp.find(s[i]) != p->mp.end()) {
            ++(p->count);
            p = p->mp[s[i]];
        } else {
            p->mp[s[i]] = new node();
            ++(p->count);
            p = p->mp[s[i]];
        }
    }
    p->isEnd = 1;
    p->count += 1;
}

void findShortestPrefixes(string s) {
	node *p = &root;
	int count = 0;
	for(int i = 0; i < s.size(); ++i) {
		if(p->count == 1) {
			res.push_back(make_pair(s, s.substr(0, count)));
			return;
		}
		p = p->mp[s[i]];
		++count;
	}
	res.push_back(make_pair(s, s.substr(0, count)));
}

int main() {
    string s;
	vector<string> v;
    while(cin >> s) {
		v.push_back(s);
    }
	for(auto i: v) {
		abjust(i);
	}
	for(auto i: v) {
		findShortestPrefixes(i);
	}
    for(auto i: res) {
        cout << i.first << " " << i.second << endl;
    }
}

一些想法

我当时犯了一个错误,就是想着一边创建字典树,一边查找最短前缀,这样是不行的,因为我们不知道所有的情况,会导致很多的错误。

应该考虑到先创建字典树,然后再查找最短前缀。这样就不会出现问题了。

相关推荐
好记性+烂笔头8 分钟前
hot100_108. 将有序数组转换为二叉搜索树
算法·leetcode·职场和发展
thinkMoreAndDoMore13 分钟前
深度学习(3)-TensorFlow入门(常数张量和变量)
开发语言·人工智能·python
tt55555555555518 分钟前
每日一题——主持人调度(二)
c语言·数据结构·算法·leetcode·八股文
技术蔡蔡35 分钟前
Android字节码处理-函数耗时统计揭秘
算法·面试
qing_04060344 分钟前
数据结构——二叉搜索树
数据结构·c++·二叉树·二叉搜索树
蓝桉8021 小时前
图片爬取案例
开发语言·数据库·python
Felven1 小时前
B. Skibidus and Ohio
算法
逸狼1 小时前
【JavaEE进阶】Spring DI
java·开发语言
yonuyeung1 小时前
代码随想录算法【Day54】
java·数据结构·算法
Ljw...1 小时前
DeepSeek+Kimi生成高质量PPT
数据库·c++·powerpoint·ppt·deepseek