ElasticSearch备考 -- 集群配置常见问题

一、集群开启xpack安全配置后无法启动

在配置文件中增加 xpack.security.enabled: true 后无法启动,日志中提示如下

复制代码
Transport SSL must be enabled if security is enabled. Please set [xpack.security.transport.ssl.enabled] to [true] or disable security by setting [xpack.security.enabled] to [false]

1)需要在配置文件中,开启ssl传输,并且配置加密秘钥路径

复制代码
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.verification_mode: certificate
xpack.security.transport.ssl.client_authentication: required
xpack.security.transport.ssl.keystore.path: elastic-certificates.p12
xpack.security.transport.ssl.truststore.path: elastic-certificates.p12

2)通过如下命令创建CA

复制代码
./bin/elasticsearch-certutil ca 

3)颁发证书

复制代码
./bin/elasticsearch-certutil cert --ca elastic-stack-ca.p12 

执行成功后后在节点路径中会增加 elastic-certificates.p12 和 elastic-stack-ca.p12 文件,

4)将这两个文件移动到 config 目录中

执行完成以上步骤后在重启服务,便可以成功

注意:如果执行启动命令还是有问题,或者在某个节点无法链接到集群,建议把data目录的中文件全部删除,在执行启动命令

二、设置用户密码失败

使用 ./elasticsearch-setup-passwords auto 设置密码失败,报错信息如下

复制代码
Unexpected response code [503] from calling PUT http://127.0.0.1:9200/_security/user/apm_system/_password?pretty
Cause: Cluster state has not been recovered yet, cannot write to the [null] index

Possible next steps:
* Try running this tool again.
* Try running with the --verbose parameter for additional messages.
* Check the elasticsearch logs for additional error details.
* Use the change password API manually. 


ERROR: Failed to set password for user [apm_system].

原因:集群没有正常启动,需要保证集群为启动状态后

三、跨集群查询失败

夸集群查询必须在集群中节点增加一个角色 remote_cluster_client_role,在官方文档中有提示说明,地址如下:Node | Elasticsearch Guide 8.1 | Elastic。这一点需要注意

送一波福利:

福利一

有需要内推JD的同学,可以私信或留言,我帮您内推,流程快!!!

有需要内推JD的同学,可以私信或留言,我帮您内推,流程快!!!

有需要内推JD的同学,可以私信或留言,我帮您内推,流程快!!!

福利二

福利三

相关推荐
量子-Alex5 小时前
【大模型强化学习后训练】强化学习后训练算力应投向何处?模型规模、搜索、学习与反馈
人工智能·学习
0+1115 小时前
Linux --应用层自定义协议与序列化
linux·运维·服务器·网络·tcp
dyxal5 小时前
Linux Crontab 防重复执行利器:flock 文件锁实战详解(脱敏版)
linux·运维·服务器
niuTaylor5 小时前
RK3568 Linux SDK 详解:SDK 是什么、板级差异与完整构建流程
linux·运维·服务器
拾贰_C5 小时前
【Ubuntu | port】Linux进程端口号冲突问题解决
linux·运维·ubuntu
wdfk_prog5 小时前
Wi-Fi Direct 教程 07:第一次 P2P Scan 如何真正发出——WPS/P2P IE、radio work 与 driver request
运维·服务器·ubuntu·wifi-direct
机核研创社5 小时前
服装自动化观察:接橡筋机的超声波熔切与冷刀,差别到底在哪
运维·自动化
欣欣之王来了5 小时前
AI合规专项:AI自动化决策的合规管控要点
运维·人工智能·自动化
guo_wen_qiang6 小时前
docker安装常见软件集合
运维·docker·容器
谷哥的小弟6 小时前
CentOS寿终正寝
linux·运维·centos