记录es收集日志报错问题as the final mapping would have more than 1 type[XXX,doc]

半路接收环境,遇见ELK日志不能创建索引接收日志的问题

es6.8版本,默认mappings的类型是doc,但是在es创建时设置了自定义模版,把这个mappings的类型改成了自定义

注:这个截图是已经改好了的

这时候就和es默认使用的type产生了冲突,es在接收到日志之后就会报错

在kibana上看见这的mapping的类型是自己设置的XXX

注:这个截图是已经改好了的

虽然冲突但还是可以收集到日志,但是在创建自定义索引的时候会因为此错误而导致创建索引时找不到对应的索引,并且默认会输出到logstash上的日志也会消失。

不管是ai还是寻找各自教程,教的都是kibana上更改索引管理中这个创建索引的mappings,通过使用开发工具各自改改改。

实际上底层这个模版是在ES已经被定义好的,上层的更改没有任何意义,想要正常还得从ES下手。

通过查看安装脚本发现,es有制作日志的模版脚本,从这里下手进行更改。

先把模版里面的自定义mappings的type类型改成doc,然后将新改好的模版重新加载,最后重启ES查看是否生效。

shell 复制代码
  curl -u elastic:密码 -XPOST http://es地址/_template/audit -H 'Content-Type:application/json' -d 模版路径

之后再到kibana里面重新查看,可以成功创建,问题解决

相关推荐
云表无代码开发7 分钟前
日本开发者彻底破防:中文太强了!换成英文直接裂开
大数据·服务器·人工智能·microsoft·信息可视化
皮皮学姐分享-ppx33 分钟前
地级市、省级人才政策强度测算(2000-2025)
大数据·数据库·人工智能·百度·高考
大大大大晴天1 小时前
面向湖仓一体的大数据安全治理:识别、授权、脱敏与审计
大数据
LBL12201 小时前
内网容器部署FTP日志监控服务
运维·服务器·容器
NailiConveyor1 小时前
输送机系统与WMS仓储管理系统集成的5个关键技术点
大数据·运维·自动化·制造·业界资讯
HZZD_HZZD1 小时前
碳排放核算只报一个数,审计凭什么信你?合众致达蒙特卡洛不确定性量化实测:25.2万度园区月账95%置信区间收窄至±2.4%
大数据·物联网
一只专注api接口开发的技术猿2 小时前
告别手工复制粘贴:搭建电商商品自动化监控与数据分析实践
大数据·运维·数据挖掘·数据分析·自动化
wtblszn2 小时前
光伏发电与光热发电有什么区别
大数据·运维·物联网
weixin_177297220692 小时前
成立三年估值80亿美元:法律AI公司Harvey给中国企业的四个启发
大数据·人工智能
ha_lydms2 小时前
MaxCompute中窗口函数
大数据·hadoop·阿里云·云计算·dataworks·maxcompute·odps