Linux命令大全-usermod命令

一、简介

usermod(英文全拼:user modify)命令用于修改用户的一些参数。比如创建的用户有一些参数写错了,就不需要删除用户再进行创建,可以使用该命令直接修改成用户正常的参数。

二、语法

**语法:**usermod 选项 登录(用户)

参数说明:

-a:将用户添加至扩展组中

-c:<备注> 修改用户的备注信息

-m:将用户家目录内容移动到新位置

-d:<登入目录> 修改用户登录时的家目录

-o:允许重复的用户ID

-e:<有效期限> 修改用户的有效期限

-p:设置用户的新密码

-f:<缓冲天数> 设置在密码过期多少天后关闭该用户

-s:<shell> 修改用户登入后所使用的shell

-g:<群组> 修改用户所属的群组

-G:<群组> 修改用户所属的附加群组

-u:<uid> 修改用户的ID

-U:解除密码锁定,使密码恢复正常

-l:<帐号名称> 修改用户名称

-L:锁定用户密码,使密码立即失效

三、实战

1 、更改一个用户的家目录

bash 复制代码
[root@app01 home]# cat /etc/passwd|grep tom
tom:x:1002:1002::/home/tom:/bin/bash
[root@app01 home]# usermod -d /app/tom tom
[root@app01 home]# cat /etc/passwd|grep tom
tom:x:1002:1002::/app/tom:/bin/bash

修改完成tom用户家目录之后,使用root用户切换到tom用户后,有时会报如下错误:

1.切换用户错误:

su: 警告:无法更改到 /app/tom 目录: 没有那个文件或目录

2.用户登录错误:

Could not chdir to home directory /app/tom: No such file or directory

这是因为新更改的家目录不存在造成的,在对应的目录下创建好对应家目录,并把家目录的用户所属权限(用户和组)修改成对应用户的权限的即解决以上的报错信息。

解决完以上问题后,大家可能会发现,登陆后或切换后用户发现用户登录提示为-bash-4.2,而不是\[tom@app01 \~\]。如下所示:

bash 复制代码
[root@app01 app]# su - tom
上一次登录:六 8月 23 21:18:28 CST 2025pts/0 上
-bash-4.2$

这是因为用户的".bash_logout、.bash_profile、.bashrc或.bash*"文件丢失造成,可以从原来的家目录下的文件复制到修改后的家目录中,也可以从/etc/skel目录把".bash_logout、.bash_profile、.bashrc或.bash*"复制到修改后的家目录中,重新登陆即可。

注:复制完成之后,记得把对应的文件用户所属权限(用户和组)修改成对应用户的权限。

2 、修改用户的用户id

bash 复制代码
[root@app01 app]# id tom
uid=1002(tom) gid=1002(tom) 组=1002(tom)
[root@app01 app]# usermod -u 1003 tom
[root@app01 app]# id tom
uid=1003(tom) gid=1002(tom) 组=1002(tom)

如果有用该用户启动一些程序,或是用户有登录且没有退出,是不能修改,修改时会报以下错误。

bash 复制代码
[root@app01 app]# usermod -u 1003 tom
usermod: user tom is currently used by process 2493

在日常的工作中,有可能会同时修改用户所属的组和附属组,此时大家可以用"-g"和"-G"来组合完成。如下:

bash 复制代码
[root@app01 app]# id tom1
uid=1002(tom1) gid=1002(tom) 组=1002(tom)
[root@app01 app]# usermod -g app -G app tom1
[root@app01 app]# id tom1
uid=1002(tom1) gid=1000(app) 组=1000(app)

有时会在原来的组中增加用户组。如下:

bash 复制代码
[root@app01 app]# usermod -aG tom tom1
[root@app01 app]# id tom1
uid=1002(tom1) gid=1000(app) 组=1000(app),1002(tom)

其中"-G"是修改,"-a"是在原来的附属组中进行新增,在目常工作中要根据实际情况进行更改,避免出现修改错误的情况发生。

3 、修改用户名称

bash 复制代码
[root@app01 app]# usermod -l tom1 tom
[root@app01 app]# id tom
id: tom: no such user
[root@app01 app]# id tom1
uid=1002(tom1) gid=1002(tom) 组=1002(tom)

修改用户名称时,新用户名称在前,旧用户名称在后,如果写返会提示用户不存在的错误。如下:

bash 复制代码
[root@app01 app]# usermod -l tom tom1
usermod:用户"tom1"不存在

注:用户名称修改完成之后,用户的家目录名称是不会修改的。

4 、锁定用户,临时不用登陆

bash 复制代码
[root@app01 app]# usermod -L tom

5 、解锁用户,可以再次登录

bash 复制代码
[root@app01 app]# usermod -U tom
相关推荐
阳光九叶草LXGZXJ5 小时前
达梦数据库-报错-15-列【XXX】长度超出定义
linux·运维·数据库·sql·学习
奔跑的大白啊6 小时前
多容器共享目录权限踩坑记
linux·ubuntu·共享目录·linux权限·docker 容器化部署
黄大刀6 小时前
DataPulse一款开箱即用的SCADA(四)-历史记录
运维·scada·动环
归秋1429 小时前
2026 企业 AI 办公工具选型指南:从评估框架到产品适配
大数据·运维·人工智能
Android系统攻城狮9 小时前
Linux Gstreamer深度解析之gst_audio_encoder_set_frame_max调用流程与实战(六十一)
android·linux·运维·音视频·gstreamer音视频·音视频进阶·gstreamer音视频进阶
H.莓飛9 小时前
【C++】命名空间、缺省参数、函数重载与引用
linux·开发语言·c++·visual studio
91刘仁德9 小时前
IP协议详解:从IP协议头到网段划分、路由与NAT
linux·服务器·网络·网络协议·tcp/ip
硅基手札10 小时前
【Linux内核专栏 14】网络协议栈
linux·运维·网络协议
沫璃染墨12 小时前
《Linux工程实践篇(一):认识设计模式——从日志系统看策略模式》
linux·c++·安全·设计模式·策略模式
工作10年+,存储芯片行业12 小时前
Linux NVMe 中断排查与性能优化:CPU 亲和性
linux·运维·服务器·windows·性能优化·ssd·pcie