子矩阵(c++实现)

题目


给定一个 n×m (n 行 m 列)的矩阵。

设一个矩阵的价值为其所有数中的最大值和最小值的乘积。

求给定矩阵的所有大小为 a×b (a 行 b 列)的子矩阵的价值的和。

答案可能很大,你只需要输出答案对 998244353 取模后的结果。


输入


输入的第一行包含四个整数分别表示 n,m,a,b,相邻整数之间使用一个空格分隔。

接下来 n行每行包含 m 个整数,相邻整数之间使用一个空格分隔,表示矩阵中的每个数 Ai,j。


输出


输出一行包含一个整数表示答案。


样例


输入样例:

2 3 1 2

1 2 3

4 5 6


输出样例:

58


CODE

c++ 复制代码
#include<iostream>
using namespace std;
const int N = 1010,MOD = 998244353;
int w[N][N];
int n,m,A,B;
int rmax[N][N],rmin[N][N];
int q[N];

void get_max(int a[],int b[],int tot,int k){
    int hh=0,tt=-1;
    for(int i=0;i<tot;i++){
        if(hh<=tt && i-k>=q[hh]) hh++;
        while(hh<=tt && a[q[tt]]<=a[i]) tt--;
        q[++tt] = i;
        b[i] = a[q[hh]];
    }
}

void get_min(int a[],int b[],int tot,int k){
    int hh=0,tt=-1;
    for(int i=0;i<tot;i++){
        if(hh<=tt && i-k>=q[hh]) hh++;
        while(hh<=tt && a[q[tt]]>=a[i]) tt--;
        q[++tt] = i;
        b[i] = a[q[hh]];
    }
}

int main(){
    scanf("%d%d%d%d",&n,&m,&A,&B);
    
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            scanf("%d",&w[i][j]);
        }
    }
    
    for(int i=0;i<n;i++){
        get_max(w[i],rmax[i],m,B);
        get_min(w[i],rmin[i],m,B);
    }
    
    int res = 0;
    int a[N],b[N],c[N];
    
    for(int i=B-1;i<m;i++){
        for(int j=0;j<n;j++) a[j] = rmax[j][i];
        get_max(a,b,n,A);
        for(int j=0;j<n;j++) a[j] = rmin[j][i];
        get_min(a,c,n,A);
        for(int j=A-1;j<n;j++){
            res = (res + (long long)b[j]*c[j])%MOD;
        }
    }
    printf("%d",res);
}
相关推荐
算AI10 小时前
人工智能+牙科:临床应用中的几个问题
人工智能·算法
我不会编程55510 小时前
Python Cookbook-5.1 对字典排序
开发语言·数据结构·python
懒羊羊大王&11 小时前
模版进阶(沉淀中)
c++
owde11 小时前
顺序容器 -list双向链表
数据结构·c++·链表·list
第404块砖头11 小时前
分享宝藏之List转Markdown
数据结构·list
GalaxyPokemon11 小时前
Muduo网络库实现 [九] - EventLoopThread模块
linux·服务器·c++
W_chuanqi11 小时前
安装 Microsoft Visual C++ Build Tools
开发语言·c++·microsoft
hyshhhh12 小时前
【算法岗面试题】深度学习中如何防止过拟合?
网络·人工智能·深度学习·神经网络·算法·计算机视觉
蒙奇D索大12 小时前
【数据结构】第六章启航:图论入门——从零掌握有向图、无向图与简单图
c语言·数据结构·考研·改行学it
A旧城以西12 小时前
数据结构(JAVA)单向,双向链表
java·开发语言·数据结构·学习·链表·intellij-idea·idea