子矩阵(c++实现)

题目


给定一个 n×m (n 行 m 列)的矩阵。

设一个矩阵的价值为其所有数中的最大值和最小值的乘积。

求给定矩阵的所有大小为 a×b (a 行 b 列)的子矩阵的价值的和。

答案可能很大,你只需要输出答案对 998244353 取模后的结果。


输入


输入的第一行包含四个整数分别表示 n,m,a,b,相邻整数之间使用一个空格分隔。

接下来 n行每行包含 m 个整数,相邻整数之间使用一个空格分隔,表示矩阵中的每个数 Ai,j。


输出


输出一行包含一个整数表示答案。


样例


输入样例:

2 3 1 2

1 2 3

4 5 6


输出样例:

58


CODE

c++ 复制代码
#include<iostream>
using namespace std;
const int N = 1010,MOD = 998244353;
int w[N][N];
int n,m,A,B;
int rmax[N][N],rmin[N][N];
int q[N];

void get_max(int a[],int b[],int tot,int k){
    int hh=0,tt=-1;
    for(int i=0;i<tot;i++){
        if(hh<=tt && i-k>=q[hh]) hh++;
        while(hh<=tt && a[q[tt]]<=a[i]) tt--;
        q[++tt] = i;
        b[i] = a[q[hh]];
    }
}

void get_min(int a[],int b[],int tot,int k){
    int hh=0,tt=-1;
    for(int i=0;i<tot;i++){
        if(hh<=tt && i-k>=q[hh]) hh++;
        while(hh<=tt && a[q[tt]]>=a[i]) tt--;
        q[++tt] = i;
        b[i] = a[q[hh]];
    }
}

int main(){
    scanf("%d%d%d%d",&n,&m,&A,&B);
    
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            scanf("%d",&w[i][j]);
        }
    }
    
    for(int i=0;i<n;i++){
        get_max(w[i],rmax[i],m,B);
        get_min(w[i],rmin[i],m,B);
    }
    
    int res = 0;
    int a[N],b[N],c[N];
    
    for(int i=B-1;i<m;i++){
        for(int j=0;j<n;j++) a[j] = rmax[j][i];
        get_max(a,b,n,A);
        for(int j=0;j<n;j++) a[j] = rmin[j][i];
        get_min(a,c,n,A);
        for(int j=A-1;j<n;j++){
            res = (res + (long long)b[j]*c[j])%MOD;
        }
    }
    printf("%d",res);
}
相关推荐
嘻嘻哈哈樱桃几秒前
前k个高频元素力扣--347
数据结构·算法·leetcode
dorabighead几秒前
小哆啦解题记:加油站的奇幻冒险
数据结构·算法
Ritsu栗子17 分钟前
代码随想录算法训练营day35
c++·算法
Tubishu26 分钟前
数据结构——实验五·图
数据结构
好一点,更好一点27 分钟前
systemC示例
开发语言·c++·算法
金融OG1 小时前
99.8 金融难点通俗解释:净资产收益率(ROE)
大数据·python·线性代数·机器学习·数学建模·金融·矩阵
卷卷的小趴菜学编程1 小时前
c++之List容器的模拟实现
服务器·c语言·开发语言·数据结构·c++·算法·list
年轮不改1 小时前
Qt基础项目篇——Qt版Word字处理软件
c++·qt
林开落L1 小时前
模拟算法习题篇
算法
玉蜉蝣1 小时前
PAT甲级-1014 Waiting in Line
c++·算法·队列·pat甲·银行排队问题