L2-4 寻宝图

给定一幅地图,其中有水域,有陆地。被水域完全环绕的陆地是岛屿。有些岛屿上埋藏有宝藏,这些有宝藏的点也被标记出来了。本题就请你统计一下,给定的地图上一共有多少岛屿,其中有多少是有宝藏的岛屿。

输入格式:

输入第一行给出 2 个正整数 N 和 M(1<N×M≤105),是地图的尺寸,表示地图由 N 行 M 列格子构成。随后 N 行,每行给出 M 位个位数,其中 0 表示水域,1 表示陆地,2-9 表示宝藏。

注意:两个格子共享一条边时,才是"相邻"的。宝藏都埋在陆地上。默认地图外围全是水域。

输出格式:

在一行中输出 2 个整数,分别是岛屿的总数量和有宝藏的岛屿的数量。

输入样例:

复制代码
10 11
01000000151
11000000111
00110000811
00110100010
00000000000
00000111000
00114111000
00110010000
00019000010
00120000001

输出样例:

复制代码
7 2

#include <bits/stdc++.h>
using namespace std;

const int dx[] = {-1, 1, 0, 0};
const int dy[] = {0, 0, -1, 1};

void bfs(int x, int y, vector<vector<char>>& grid, bool& hasTreasure) {
    int n = grid.size();
    int m = grid[0].size();

    queue<pair<int, int>> q;
    q.push({x, y});

    // 标记当前格子为已访问
    grid[x][y] = '0';

    while (!q.empty()) {
        auto [cx, cy] = q.front();
        q.pop();

        // 检查当前格子是否是宝藏
        if (grid[cx][cy] >= '2' && grid[cx][cy] <= '9') {
            hasTreasure = true;
        }

        // 遍历四个方向
        for (int i = 0; i < 4; i++) {
            int nx = cx + dx[i];
            int ny = cy + dy[i];
            if (nx >= 0 && nx < n && ny >= 0 && ny < m && grid[nx][ny] != '0') {
                grid[nx][ny] = '0'; // 标记为已访问
                q.push({nx, ny});
            }
        }
    }
}

void solve() {
    int n, m;
    cin >> n >> m;
    vector<vector<char>> grid(n, vector<char>(m));

    // 读取地图
    for (int i = 0; i < n; i++) {
        for (int j = 0; j < m; j++) {
            cin >> grid[i][j];
        }
    }

    int totalIslands = 0;
    int treasureIslands = 0;

    // 遍历地图
    for (int i = 0; i < n; i++) {
        for (int j = 0; j < m; j++) {
            if (grid[i][j] != '0') {
                bool hasTreasure = false;
                bfs(i, j, grid, hasTreasure);
                totalIslands++;
                if (hasTreasure) {
                    treasureIslands++;
                }
            }
        }
    }

    // 输出结果
    cout << totalIslands << " " << treasureIslands << endl;
}

int main() {
    ios::sync_with_stdio(0);
    cin.tie(0), cout.tie(0);
    solve();
    return 0;
}

#include <bits/stdc++.h>
using namespace std;
const int dx[] = {-1, 1, 0, 0};
const int dy[] = {0, 0, -1, 1};
void dfs(int x, int y, vector<vector<char>>& grid, bool& hasTreasure) {
    int n = grid.size();
    int m = grid[0].size();
    if (grid[x][y] >= '2' && grid[x][y] <= '9') {
        hasTreasure = true;
    }
    grid[x][y] = '0';
    for (int i = 0; i < 4; i++) {
        int nx = x + dx[i];
        int ny = y + dy[i];
        if (nx >= 0 && nx < n && ny >= 0 && ny < m && grid[nx][ny] != '0') {
            dfs(nx, ny, grid, hasTreasure);
        }
    }
}
void solve() {
    int n, m;
    cin >> n >> m;
    vector<vector<char>> grid(n, vector<char>(m));
    for (int i = 0; i < n; i++) {
        for (int j = 0; j < m; j++) {
            cin >> grid[i][j];
        }
    }
    int totalIslands = 0;
    int treasureIslands = 0;
    for (int i = 0; i < n; i++) {
        for (int j = 0; j < m; j++) {
            if (grid[i][j] != '0') {
                bool hasTreasure = false;
                dfs(i, j, grid, hasTreasure);
                totalIslands++;
                if (hasTreasure) {
                    treasureIslands++;
                }
            }
        }
    }
    cout << totalIslands << " " << treasureIslands << endl;
}

int main() {
    ios::sync_with_stdio(0);
    cin.tie(0), cout.tie(0);
    solve();
    return 0;
}
相关推荐
算AI9 小时前
人工智能+牙科:临床应用中的几个问题
人工智能·算法
我不会编程55510 小时前
Python Cookbook-5.1 对字典排序
开发语言·数据结构·python
owde11 小时前
顺序容器 -list双向链表
数据结构·c++·链表·list
第404块砖头11 小时前
分享宝藏之List转Markdown
数据结构·list
hyshhhh11 小时前
【算法岗面试题】深度学习中如何防止过拟合?
网络·人工智能·深度学习·神经网络·算法·计算机视觉
蒙奇D索大11 小时前
【数据结构】第六章启航:图论入门——从零掌握有向图、无向图与简单图
c语言·数据结构·考研·改行学it
A旧城以西12 小时前
数据结构(JAVA)单向,双向链表
java·开发语言·数据结构·学习·链表·intellij-idea·idea
杉之12 小时前
选择排序笔记
java·算法·排序算法
烂蜻蜓12 小时前
C 语言中的递归:概念、应用与实例解析
c语言·数据结构·算法
OYangxf12 小时前
图论----拓扑排序
算法·图论