头插法创建单链表、遍历链表、删除链表 | C语言代码

题目:

输入一系列自然数(0和正整数),输入-1时表示输入结束。按照输入的顺序,用头插法建立单链表,并遍历所建立的单链表,输出这些数据。注意 -1 不加入链表。

输入格式:

第一行是一个正整数k,表示以下会有k组测试数据。

每组测试数据是一系列以空格隔开的自然数(0和正整数)。数列末尾的 -1 表示本组测试数据结束。按照输入的顺序,用头插法建立单链表,并遍历所建立的单链表,输出这些数据。注意 -1 不加入链表。

输出格式:

对于每组测试数据,输出链表中各节点的数据域。每个数据后有一个空格。每组测试数据的输出占1行。

输入样例:

3

1 2 3 4 5 -1

30 20 10 -1

4 2 2 1 1 2 0 2 -1

输出样例:

5 4 3 2 1

10 20 30

2 0 2 1 1 2 2 4

代码:

cpp 复制代码
#include <stdio.h>
#include <stdlib.h>

// 定义单链表节点结构
struct Node {
    int data; // 数据域
    struct Node* next; // 指针域
};

// 创建链表的函数
struct Node* createLinkedList() {
    struct Node* head = NULL;
    int value;
 	
 	// 输入链表元素
    while (1) {
        scanf("%d", &value);
        
		// 判断是否插入节点
        if (value == -1) {
            break;
        }

		// 头插法
        struct Node* newNode = (struct Node*)malloc(sizeof(struct Node));
        newNode->data = value;
        newNode->next = head;
        head = newNode;
    }

    return head;
}

// 遍历链表
void traverseAndPrint(struct Node* head) {
    struct Node* current = head;
    while (current != NULL) {
        printf("%d ", current->data);
        current = current->next;
    }
    printf("\n");
}

// 删除链表释放内存
void deleteLinkedList(struct Node* head) {
    struct Node* current = head;
    while (current != NULL) {
        struct Node* temp = current;
        current = current->next;
        free(temp);
    }
}

int main() {
	// 输入链表节点个数
    int k;
    scanf("%d", &k);

	// 输入元素
    for (int i = 0; i < k; i++) {
        struct Node* head = createLinkedList();
        traverseAndPrint(head);
        deleteLinkedList(head);
    }

    return 0;
}
相关推荐
算AI16 小时前
人工智能+牙科:临床应用中的几个问题
人工智能·算法
我不会编程55516 小时前
Python Cookbook-5.1 对字典排序
开发语言·数据结构·python
懒羊羊大王&17 小时前
模版进阶(沉淀中)
c++
似水এ᭄往昔17 小时前
【C语言】文件操作
c语言·开发语言
owde17 小时前
顺序容器 -list双向链表
数据结构·c++·链表·list
第404块砖头17 小时前
分享宝藏之List转Markdown
数据结构·list
GalaxyPokemon17 小时前
Muduo网络库实现 [九] - EventLoopThread模块
linux·服务器·c++
W_chuanqi18 小时前
安装 Microsoft Visual C++ Build Tools
开发语言·c++·microsoft
hyshhhh18 小时前
【算法岗面试题】深度学习中如何防止过拟合?
网络·人工智能·深度学习·神经网络·算法·计算机视觉
蒙奇D索大18 小时前
【数据结构】第六章启航:图论入门——从零掌握有向图、无向图与简单图
c语言·数据结构·考研·改行学it