宝塔部署appache部署ssl证书无法访问443端口

原因:

不是部署方法错误,而是操作不当,原来一开始为了测试我去修改了appache默配置路径下的httpd-ssl.donf,此文件一般 在appche/conf/extra/目录下(版本不同目录可能有所区别)。

导致问题:

在默认目录配置了443端口之后(证书没有配置),又在宝塔创建的网站目录,将自己下载的新的证书部署了到443端口上去,就发现无法访问宝塔创建的网站,但是此时使用8085(任何其它除80端口的可正常访问的端口)去部署ssl证书却可以访问。据此可知,虽然appache没有报错,但是在读取配置时,它是将默认的配置作为了最终运行的配置。去删除掉默认一开始在默认配置文件写的配置(或者将宝塔面板网站的配置覆盖默认的ssl配置部分),发现终于可以访问ssl了。

解决思路:发现443配置ssl不行,尝试了8085(其它端口)发现可以,于是怀疑缺少配置或者哪里配置有误,最后逐一查看配置。

注意事项:就是使用宝塔的用户很多都是直接看宝塔展示的配置,像这个情况,就是看到工期结束都不可能解决,注意一定要看软件安装路径本身内部的配置文件! 一定要看软件安装路径本身内部的配置文件 一定要看软件安装路径本身内部的配置文件 宝塔只要是某个软件出问题解决不了,就不要再用面板看情况一定要检查安装目录内文件才是最全面的

相关推荐
java_logo2 分钟前
Docker 部署 OpenViking:轻松搭建 AI Agent 上下文数据库平台
数据库·人工智能·docker·agent·火山引擎·openviking·轩辕镜像
RoboWizard4 分钟前
搭配W790芯片组的超频服务器内存(架构选型)FAQ合集
运维·服务器·架构
2402_882893866 分钟前
Linux 进程概念详解(上)—— 从冯诺依曼体系到僵尸进程与孤儿进程
linux·运维·服务器
Codiggerworld6 分钟前
Redis 正式接入 AI:当“最懂速度的数据库“开始解决“记忆问题“
数据库·人工智能·redis
白露与泡影7 分钟前
Redis 正式接入 AI:当“最懂速度的数据库“开始解决“记忆问题“
数据库·人工智能·redis
qetfw11 分钟前
Debian iptables 防火墙:默认拒绝、SNAT 与 DNAT 验证
linux·服务器·debian·php
格物致胜工业数智技术13 分钟前
皮尔磁纸板进料安全方案运维实录:O300传感器用了三年的个人体会
运维·安全
夜之眷属14 分钟前
服务启动即崩:InetAddress.getLocalHost() 抛 UnknownHostException 排查记
java·运维·后端·docker
我不会插花弄玉15 分钟前
3.通用命令【由浅入深-redis】
数据库·redis·bootstrap
可涵不会debug21 分钟前
实测ToDesk新终端:跨端会话恢复+多终端并行,远程Vibe Coding的完整体验报告
运维·电脑