1105 链表合并——PAT乙级

给定两个单链表 L1​=a1​→a2​→⋯→an−1​→an​ 和 L2​=b1​→b2​→⋯→bm−1​→bm​。如果 n≥2m,你的任务是将比较短的那个链表逆序,然后将之并入比较长的那个链表,得到一个形如 a1​→a2​→bm​→a3​→a4​→bm−1​⋯ 的结果。例如给定两个链表分别为 6→7 和 1→2→3→4→5,你应该输出 1→2→7→3→4→6→5。

输入格式:

输入首先在第一行中给出两个链表 L1​ 和 L2​ 的头结点的地址,以及正整数

N (≤105),即给定的结点总数。一个结点的地址是一个 5 位数的非负整数,空地址 NULL 用 -1 表示。

随后 N 行,每行按以下格式给出一个结点的信息:

复制代码
Address Data Next

其中 Address 是结点的地址,Data 是不超过 105 的正整数,Next 是下一个结点的地址。题目保证没有空链表,并且较长的链表至少是较短链表的两倍长。

输出格式:

按顺序输出结果链表,每个结点占一行,格式与输入相同。

输入样例:

复制代码
00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1

输出样例:

复制代码
01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1

solution:

cpp 复制代码
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define endl '\n'
const int maxn=1e5+5;
int main()
{
	int start1,start2,n;
	cin>>start1>>start2>>n;
	int data[maxn],next[maxn];
	for(int i=0;i<n;i++)
	{
		int tmp;cin>>tmp;
		cin>>data[tmp]>>next[tmp];
	}
	vector<pair<int,int> >list1,list2;
	int cnt1=0,cnt2=0;
	while(start1!=-1)
	{
		cnt1++;
		list1.push_back({start1,data[start1]});
		start1=next[start1];
	}
	while(start2!=-1)
	{
		cnt2++;
		list2.push_back({start2,data[start2]});
		start2=next[start2];
	}
	if(cnt1<cnt2)//交换大小后,list的长度也需要交换 
	{
		swap(list1,list2);
		swap(cnt1,cnt2);
	}
	
	//reverse(list2.begin(),list2.end());//整理,这句反转不需要,因为之后j倒序输入 
	
	vector<pair<int,int> >ans;
	int i=0;
	int j=cnt2-1;
	while(i<cnt1 || j>=0)
	{
		if(i<cnt1)
		{
			ans.push_back({list1[i].first,list1[i].second});
			i++;
		}
		if(i<cnt1)
		{
			ans.push_back({list1[i].first,list1[i].second});
			i++;
		}
		if(j>=0)
		{
			ans.push_back({list2[j].first,list2[j].second});//反转 
			j--;
		}
	}
	for(int i=0;i<ans.size()-1;i++)
	{
		printf("%05d %d %05d\n",ans[i].first,ans[i].second,ans[i+1].first);
	}
	printf("%05d %d -1\n",ans[ans.size()-1].first,ans[ans.size()-1].second);
	return 0;
}
相关推荐
算AI8 小时前
人工智能+牙科:临床应用中的几个问题
人工智能·算法
我不会编程5559 小时前
Python Cookbook-5.1 对字典排序
开发语言·数据结构·python
懒羊羊大王&9 小时前
模版进阶(沉淀中)
c++
owde9 小时前
顺序容器 -list双向链表
数据结构·c++·链表·list
第404块砖头10 小时前
分享宝藏之List转Markdown
数据结构·list
GalaxyPokemon10 小时前
Muduo网络库实现 [九] - EventLoopThread模块
linux·服务器·c++
W_chuanqi10 小时前
安装 Microsoft Visual C++ Build Tools
开发语言·c++·microsoft
hyshhhh10 小时前
【算法岗面试题】深度学习中如何防止过拟合?
网络·人工智能·深度学习·神经网络·算法·计算机视觉
蒙奇D索大10 小时前
【数据结构】第六章启航:图论入门——从零掌握有向图、无向图与简单图
c语言·数据结构·考研·改行学it
A旧城以西10 小时前
数据结构(JAVA)单向,双向链表
java·开发语言·数据结构·学习·链表·intellij-idea·idea