1028 List Sorting

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 9

Sample Output 3:

000002 James 9
000001 Zoe 60
000007 James 85
000010 Amy 90

solution:

cpp 复制代码
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define endl '\n'
struct node
{
	int id;
	string ids;
	string name;
	int grade;
};
int main()
{
	ios::sync_with_stdio(false);cin.tie(0);
	int n,m;cin>>n>>m;
	vector<node>a(n);
	for(int i=0;i<n;i++)
	{
		cin>>a[i].ids>>a[i].name>>a[i].grade;
		a[i].id=stoi(a[i].ids); 
	}
	if(m==1)
	{
		sort(a.begin(),a.end(),[](node a,node b)
		{
			return a.id<b.id;
		});
	}
	else if(m==2)
	{
		sort(a.begin(),a.end(),[](node a,node b)
		{
			if(a.name==b.name)return a.id<b.id;
			return a.name<b.name;
		});
	}
	else if(m==3)
	{
		sort(a.begin(),a.end(),[](node a,node b)
		{
			if(a.grade==b.grade)return a.id<b.id;
			return a.grade<b.grade;
		});
	}
	for(int i=0;i<a.size();i++)
	{
		cout<<a[i].ids<<' '<<a[i].name<<' '<<a[i].grade<<endl;
	}
}
相关推荐
摆烂小白敲代码6 分钟前
大一新生以此篇开启你的算法之路
c语言·数据结构·c++·人工智能·经验分享·算法
DSLMing8 分钟前
C++ 使用 glm 实现 Cartesian3.fromDegrees
开发语言·c++
y_dd9 分钟前
【mechine learning-六-supervise learning之线性回归模型】
算法·回归·线性回归
爱吃芝麻汤圆9 分钟前
349. 两个数组的交集-LeetCode(C++)
c++·leetcode
Navigator_Z1 小时前
LeetCode //C - 363. Max Sum of Rectangle No Larger Than K
c语言·算法·leetcode
孤独且没人爱的纸鹤1 小时前
C++类和对象(上)
c语言·开发语言·c++
鱼跃鹰飞2 小时前
Leetcode面试经典150题-138.随机链表的复制
算法·leetcode·链表·面试
不是仙人的闲人2 小时前
C++ 标准库的典型内容
开发语言·c++
松小白song2 小时前
常量指针、指针常量及常量指针常量
算法
Cyan_RA92 小时前
C 408—《数据结构》算法题基础篇—链表(上)
java·数据结构·算法·链表·c·408·计算机考研