1028 List Sorting

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

复制代码
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

复制代码
000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

复制代码
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

复制代码
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

复制代码
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 9

Sample Output 3:

复制代码
000002 James 9
000001 Zoe 60
000007 James 85
000010 Amy 90

solution:

cpp 复制代码
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define endl '\n'
struct node
{
	int id;
	string ids;
	string name;
	int grade;
};
int main()
{
	ios::sync_with_stdio(false);cin.tie(0);
	int n,m;cin>>n>>m;
	vector<node>a(n);
	for(int i=0;i<n;i++)
	{
		cin>>a[i].ids>>a[i].name>>a[i].grade;
		a[i].id=stoi(a[i].ids); 
	}
	if(m==1)
	{
		sort(a.begin(),a.end(),[](node a,node b)
		{
			return a.id<b.id;
		});
	}
	else if(m==2)
	{
		sort(a.begin(),a.end(),[](node a,node b)
		{
			if(a.name==b.name)return a.id<b.id;
			return a.name<b.name;
		});
	}
	else if(m==3)
	{
		sort(a.begin(),a.end(),[](node a,node b)
		{
			if(a.grade==b.grade)return a.id<b.id;
			return a.grade<b.grade;
		});
	}
	for(int i=0;i<a.size();i++)
	{
		cout<<a[i].ids<<' '<<a[i].name<<' '<<a[i].grade<<endl;
	}
}
相关推荐
·醉挽清风·2 分钟前
学习笔记—双指针算法—移动零
c++·笔记·学习·算法
几点才到啊6 分钟前
使用 malloc 函数模拟开辟一个 3x5 的整型二维数组
数据结构·算法
编程绿豆侠33 分钟前
力扣HOT100之链表:23. 合并 K 个升序链表
算法·leetcode·链表
Ayanami_Reii35 分钟前
Leetcode837.新21点
c++·笔记·算法
我想进大厂36 分钟前
图论---最大流(Dinic)
算法·深度优先·图论
brzhang1 小时前
效率神器!TmuxAI:一款无痕融入终端的AI助手,让我的开发体验翻倍提升
前端·后端·算法
simple_whu2 小时前
Visual Studio C/C++编译器cl.exe的/source-charset与/execution-charset设置项
c语言·c++·visual studio
GOATLong2 小时前
网络基础概念
linux·运维·服务器·网络·arm开发·c++
工藤新一¹2 小时前
C++/SDL 进阶游戏开发 —— 双人塔防(代号:村庄保卫战 14)
开发语言·c++·游戏引擎·游戏开发·sdl·实践项目
<但凡.3 小时前
C++修炼:list模拟实现
开发语言·数据结构·c++