1028 List Sorting

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 9

Sample Output 3:

000002 James 9
000001 Zoe 60
000007 James 85
000010 Amy 90

solution:

cpp 复制代码
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define endl '\n'
struct node
{
	int id;
	string ids;
	string name;
	int grade;
};
int main()
{
	ios::sync_with_stdio(false);cin.tie(0);
	int n,m;cin>>n>>m;
	vector<node>a(n);
	for(int i=0;i<n;i++)
	{
		cin>>a[i].ids>>a[i].name>>a[i].grade;
		a[i].id=stoi(a[i].ids); 
	}
	if(m==1)
	{
		sort(a.begin(),a.end(),[](node a,node b)
		{
			return a.id<b.id;
		});
	}
	else if(m==2)
	{
		sort(a.begin(),a.end(),[](node a,node b)
		{
			if(a.name==b.name)return a.id<b.id;
			return a.name<b.name;
		});
	}
	else if(m==3)
	{
		sort(a.begin(),a.end(),[](node a,node b)
		{
			if(a.grade==b.grade)return a.id<b.id;
			return a.grade<b.grade;
		});
	}
	for(int i=0;i<a.size();i++)
	{
		cout<<a[i].ids<<' '<<a[i].name<<' '<<a[i].grade<<endl;
	}
}
相关推荐
我是谁??17 分钟前
C/C++使用AddressSanitizer检测内存错误
c语言·c++
小码农<^_^>19 分钟前
优选算法精品课--滑动窗口算法(一)
算法
羊小猪~~21 分钟前
神经网络基础--什么是正向传播??什么是方向传播??
人工智能·pytorch·python·深度学习·神经网络·算法·机器学习
软工菜鸡1 小时前
预训练语言模型BERT——PaddleNLP中的预训练模型
大数据·人工智能·深度学习·算法·语言模型·自然语言处理·bert
南宫生1 小时前
贪心算法习题其三【力扣】【算法学习day.20】
java·数据结构·学习·算法·leetcode·贪心算法
发霉的闲鱼1 小时前
MFC 重写了listControl类(类名为A),并把双击事件的处理函数定义在A中,主窗口如何接收表格是否被双击
c++·mfc
小c君tt1 小时前
MFC中Excel的导入以及使用步骤
c++·excel·mfc
xiaoxiao涛1 小时前
协程6 --- HOOK
c++·协程
AI视觉网奇1 小时前
sklearn 安装使用笔记
人工智能·算法·sklearn
JingHongB2 小时前
代码随想录算法训练营Day55 | 图论理论基础、深度优先搜索理论基础、卡玛网 98.所有可达路径、797. 所有可能的路径、广度优先搜索理论基础
算法·深度优先·图论